Professional Archive - Platform
Incident Report for Smarsh
Resolved
The issue has been identified and fixed. Access to the Professional Archive is now restored. This issue is resolved.
Posted 2 months ago. Jul 17, 2019 - 15:53 PDT
Investigating
An issue has occurred with the Professional Archiving platform requiring emergency maintenance.

Next update 16:00 PDT.
Posted 2 months ago. Jul 17, 2019 - 14:37 PDT
This incident affected: Archiving Services (Archiving Platform).