Professional Archive Platform
Incident Report for Smarsh
Resolved
Access to the Professional Archive platform has been restored.
Posted about 1 month ago. Aug 13, 2019 - 17:01 PDT
Investigating
The Platform is temporarily unavailable. During this time all of your data will be securely saved and protected, but access to the platform and search functionality is temporarily unavailable.

Thank you,

Smarsh Support Team
Posted about 1 month ago. Aug 13, 2019 - 16:40 PDT
This incident affected: Archiving Services (Archiving Platform).